[WG-InfoSharing] Review CR 1.1.0 DRAFT 5

David Turner david.turner at voltagegate.com
Fri Oct 27 22:17:06 UTC 2017


Hello All,

DRAFT 5 is now on the wiki:

   - Marked up version - Consent Receipt Specification 1_1_0 DRAFT 5a.docx
   <https://kantarainitiative.org/confluence/download/attachments/76447870/Consent%20Receipt%20Specification%201_1_0%20DRAFT%205a.docx?version=1&modificationDate=1508987029000&api=v2>
   - Clean version - Consent Receipt Specification 1_1_0 DRAFT 5a -
   clean.docx
   <https://kantarainitiative.org/confluence/download/attachments/76447870/Consent%20Receipt%20Specification%201_1_0%20DRAFT%205a%20-%20clean.docx?version=1&modificationDate=1508987041000&api=v2>
   - JSON schema - CR Schema v1_1_0 DRAFT 5.json
   <https://kantarainitiative.org/confluence/download/attachments/76447870/CR%20Schema%20v1_1_0%20DRAFT%205.json?version=1&modificationDate=1508987053000&api=v2>


Please submit your comments and proposed changes to this list using a
marked-up version of the Word doc or a description that uses the document's
line numbers.If you want something changed or added, please provide a
specific proposal for the changed/new text. It is not sufficient to say,
"this paragraph requires elaboration"
without suggesting new text.

The deadline for this round of comments is Nov 9.
---------------------------------------------
I want to highlight a few things:

   1. I made significant changes to the layout and structure of the
   document:
   1. Table 1 and Table 2 have been combined into a single list; and
      2. All normative parts of the document are now in one section.
   2. I added some "editor's comments" to the document. They are the bright
   yellow text boxes with a red border. They are meant to highlight specific
   issues.

One issue I want to call out is my proposal for changing the section of the
schema for 'purpose'. (This is the same as the editor's comment at line
355.) I propose changing ‘purposes’ to type: object, creating a new element
called ‘purpose’, type: object, and renaming the current ‘purpose’ element
to ‘purposeDesc’. This will give a cleaner and less ambiguous JSON
structure.

-----------------------------------

Current structure:

purposes

    purposeDesc

    consentType

    etc.

    purposeDesc

    consentType

    etc.

-----------------------------------
Proposed structure:

purposes

    purpose

        purposeDesc

        consentType

        etc.

    purpose

        purposeDesc

        consentType

        etc.

-----------------------------------

I'm also proposing we do the same for "piiController' and 'service".

David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://kantarainitiative.org/pipermail/wg-infosharing/attachments/20171027/007f1bc3/attachment.html>


More information about the WG-InfoSharing mailing list